BetaTesting - AWS outage affecting some of BetaTesting's third party service providers – Incident details

AWS outage affecting some of BetaTesting's third party service providers

Resolved
Degraded performance
Started 7 months agoLasted 1 day

Affected

Web Platform (Logged In)

Operational from 9:30 PM to 10:29 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    There is an Amazon outage affecting AWS services, including some of BetaTesting's third party service providers. Notably, Onfido/Entrust appears to be affected, and testers may be unable to complete verification requirements while the service is experiencing issues.